Корпорация Apple с момента появления движения «права на ремонт» старалась противостоять ему. Она старалась мешать введению новых правил относительно ремонта электронных устройств в США, Европе и других странах. Но с течением времени ей пришлось немного ослабить свои позиции, поскольку законодатели все же разрабатывали все новые и новые правила, которые давали больше прав потребителям, то есть нам с вами. Собственно говоря, другие компании тоже не особо приветствовали новые законы, включая …
Совсем недавно мы писали о том, что большинство производителей электроники не справляется с заказами клиентов. Так, для того, чтобы получить необходимые компоненты для своих устройств, крупным и не очень компаниям приходилось заключать контракты на 1, 2, а то и 3 года с TSMC и другими подрядчиками. И стоимость компонентов в таких контрактах была фиксированной на весь срок действия договора в пользу подрядчиков, конечно. И даже в этом случае не всем компаниям удавалось заключить договоры …
Разработчики GIMP стараются изо всех сил, чтобы приблизить момент выхода стабильной ветки GIMP 3.0. Стоит напомнить, что она переведена на GTK3. Кроме того, команда активно работает над добавлением поддержки Wayland и HiDPI, CMYK. Также почищена кодовая база, добавлено кэширование отрисовки, есть возможность выделения нескольких слоёв. Не стоит забывать и о новом API для разработки плагинов к GIMP. Хорошая новость ещё и в том, что следующий выпуск получит статус кандидата в релизы GIMP 3.0. Ну…
В этой статье мы детально разбираемся: как на самом деле работает этот ваш SWIFT, каким образом россияне теряют огромные суммы денег в недрах зарубежных банков из-за неудачных переводов, и, самое главное, – что конкретно нужно делать, чтобы ваш перевод долетел куда надо в сухости и комфорте?Мой соавтор по этой статье, Андрей Авраменко, собрал информацию о более чем 8000 межбанковских переводах и на личном опыте знает, каково это – когда SWIFT-перевод с твоими баксами безвозвратно захавал амери…
Мотивация написания статьиВсем нам предстоит поддерживать уже существующий код, а также проводить ревью кода коллег. Иногда становится очень тяжело видеть некоторые паттерны, которые кажутся безобидными, но при некорректном использовании или после неосторожного рефакторинга могут привести к различным проблемам:утечке горутин и каналовповреждению целостности структур данныхпаникамтрудноуловимым багам в бизнес-логикесамому страшному - неутолимому желанию порефакторить код, который выглядит как т…
A blazing fast multi-language serialization framework powered by jit and zero-copy Fury is a blazing fast multi-language serialization framework powered by jit(just-in-time compilation) and zero-copy, providing up to 170x performance and ultimate ease of use. https://furyio.org Features Multiple languages: Java/Python/C++/Golang/Javascript. Zero-copy: cross-language out-of-band serialization inspired by pickle5 and off-heap read/write. High performance: A highly-extensible JIT framework to…
Multi-chain golang signature sdk, supports bitcoin, ethereum, aptos, cosmos, etc.go-wallet-sdk This is a Go language wallet solution that supports offline transactions. We currently support various mainstream public blockchains, and will gradually release the source codes for each blockchain. Supported chains BTC: Supports transaction creation and signing. Also Supports BRC20-related functions, including inscription creation, BRC20 buying and selling. Ethereum: Supports transaction creation an…
Fast and memory-efficient exact attentionFlashAttention This repository provides the official implementation of FlashAttention and FlashAttention-2 from the following papers. FlashAttention: Fast and Memory-Efficient Exact Attention with IO-Awareness Tri Dao, Daniel Y. Fu, Stefano Ermon, Atri Rudra, Christopher Ré Paper: https://arxiv.org/abs/2205.14135 IEEE Spectrum article about our submission to the MLPerf 2.0 benchmark using FlashAttention. FlashAttention-2: Faster Attention with Better Pa…
Secure & Modern All-in-One Mail Server (IMAP, JMAP, SMTP)Stalwart Mail Server Stalwart Mail Server is an open-source mail server solution with JMAP, IMAP4, and SMTP support and a wide range of modern features. It is written in Rust and designed to be secure, fast, robust and scalable. Key features: JMAP server: JMAP Core (RFC 8620) JMAP Mail (RFC 8621) JMAP over WebSocket (RFC 8887) JMAP for Sieve Scripts (DRAFT-SIEVE-13) IMAP4 server: IMAP4rev2 (RFC 9051) full compliance. IMAP4rev1 (…